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SECTION 1: DUAL BAND MIMO PIFA ANTENNA 

Prepared by: Kobina Ackon Annan & Sean Donkor (Telecom Eng. 2021) 

 

INTRODUCTION 

ANSYS HFSS is a 3D electromagnetic (EM) simulation software for designing and simulating 

high frequency electronic products such as antennas, antenna arrays, RF or microwave 

components, high speed interconnects, filters, connectors, IC packages a printed circuit board. 

Engineers worldwide use ANSYS HFSS software to design high frequency, high speed electronics 

found in communication systems, satellites and IoT products.  

This book introduces the structure and design of a dual band MIMO PIFA antenna for Bluetooth 

and WIFI application in laptops operating at 2400/5000 for Wi-Fi and 2450 for Bluetooth. This 

guide will typically walk you through the steps to build the geometry, setup the solution, run the 

analysis, and evaluate the results by generating plots using ANSYS HFSS 2020.  

By following the steps in this guide you will learn how to perform the following tasks in HFSS:  

1. Draw the geometric models.  

2. Add the boundaries and excitation.  

3. Specify solution setting for the design.  

4. Run HFSS transient simulation.  

5. Create plots for the results.  

 

 

For basic design tutorials using HFSS: 

https://www.youtube.com/playlist?list=PLdIVd39LNkpSaTzAFCS_jh3sV3Gc21mNg  

 

 

 

 

https://www.youtube.com/playlist?list=PLdIVd39LNkpSaTzAFCS_jh3sV3Gc21mNg
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1. STARTING HFSS  

To be able to start the project you would have to first start or launch the software.  

➢ Launching ANSYS Electronics Desktop 2015  

a. Select Programs > ANSYS Electromagnetics > ANSYS EM Suite 2020 R1  

b. Select ANSYS Electronics Desktop 2020 R1  

 

2. CREATING THE PROJECT  

➢ To begin working with geometrics you need to insert an HFSS design.  

a. From the toolbar, double click on the HFSS icon to open an HFSS project.  
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3. WORKING WITH THE GEOMETRICS  

➢ On the left side of the HFSS window, right click on Project from the Project Manager 

pane.  

a. Select Save As from the pop up.  

 

b. Enter the File name as DUAL BAND MIMO PIFA ANTENNA  

c. Select Save  
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4. DRAW THE GEOMETRIC MODELS  

 

❖ Creating the Radiating Patch.  

➢ From the Draw Ribbon Tab, select the rectangle tool  

➢ In the Modeler Window, click and drag from the origin to draw the rectangle.  
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➢ From the History Tree, right click on the CreateRectangle to change the dimensions and 

position of the rectangle.  

▪ Position: 0, 0, 0 mm  

▪ Axis: Z  

▪ Xsize: 36 mm 

▪ Ysize: 3 mm 

➢ Select Apply 

➢ Select OK  

 

 

➢ From the History Tree, right click on the Rectangle1 to change its properties. 

▪ Name: Patch  

▪ Material: Copper  

▪ Colour: Blue 

▪ Transparency: 0.6 

➢ Select Apply  

➢ Select OK  

 

 

 

 

5. CREATING THE SLOTS.  

 

➢ From the Draw Ribbon Tab, select the Rectangle tool.  

➢ In the Modeler Window, click and drag to draw the rectangle.  

➢ From the History Tree, right click on the CreateRectangle to change the dimensions and 

position of the rectangle.  

▪ Position: 27.1 ,2 ,0 mm  

▪ Axis: Z  

▪ Xsize: -12.51 mm  

▪ Ysize: 0.1 mm  
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➢ Select Apply Select OK 

➢ Draw another rectangle  

➢ From the History Tree, right click on the CreateRectangle to change the dimensions and 

position of the rectangle.  

▪ Position: 27 ,0 ,0 mm  

▪ Axis: Z  

▪ Xsize: 0.1 mm  

▪ Ysize: 2 mm  

➢ Select Apply  

➢ Select OK  

➢ Select the patch and two rectangles 

together  

➢ Select Subtract from the Ribbon Tab.  

➢ Move Patch under Blank Parts  

➢ Move Rectangle1 and Rectangle2 under 

Tool Parts.  

➢ Select OK.  

➢ Select Rectangle1 > Select Thicken Sheet > Set the value to 0.05 mm.  
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6. CREATING THE SHORTING PLATE.  

 

➢ From the Draw Ribbon Tab, select the rectangle tool  

➢ In the Modeler Window, click and drag from the origin to draw the rectangle.  

 

 

 

 

 

 

 

 

➢ From the History Tree, right click on CreateRectangle under Rectangle2 to change the 

dimensions and position of the rectangle.  

▪ Position: 0, 0, -0.5 mm  

▪ Axis: X  

▪ Ysize: 3 mm  

▪ Zsize: 0.5 mm  

➢ Select Apply  

➢ Select OK  

➢ Select Rectangle2 > Select Thicken 

Sheet > Set the value to 0.05 mm  

 

➢ From the History Tree, right click on the Rectangle2 to change its properties.  

▪ Name: Short  

▪ Material: Copper  

▪ Colour: default  

▪ Transparency: 0  

➢ Select Apply  

➢ Select OK  
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7. CREATING THE FEEDING PORT.  

 

➢ From the Draw Ribbon Tab, select the circle tool.  

➢ In the Modeler Window, click and drag to draw the circle.  

 

➢ From the History Tree, right click on CreateCircle under Circle1 to change the dimensions 

and position of the circle.  

▪ Position: 5 ,1 ,-5.3 mm  

▪ Axis: Z  

▪ Radius: 3 mm  

▪ Number of Seg: 0  

➢ Select Apply  

➢ Select OK  

 

 

 

 

8. CREATING THE FEED LINE.  

 

➢ From the Draw Ribbon Tab, select the cylinder tool.  

➢ In the Modeler Window, click and drag to draw the cylinder.  
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➢ From the History Tree, right click on CreateCylinder under Cylinder1 to change the 

dimensions and position of the cylinder.  

▪ Center Position: 5, 1, -5.3 mm  

▪ Axis: Z  

▪ Radius: 0.1 mm  

▪ Height: 5.35 mm  

▪ Number of Seg: 0  

➢ Select Apply  

➢ Select OK  

 

 

 

➢ From the History Tree, right click on the Cylinder1 to change its properties.  

▪ Name: feed  

▪ Material: Copper  

▪ Colour: brown  

▪ Transparency: 0  

➢ Select Apply  

➢ Select OK  

 

 



10 

 

9. CREATING THE FEED LINE COVER.  

 

➢ From the Draw Ribbon Tab select the Cylinder tool.  

➢ In the Modeler Window, click and drag to draw the circle.  

 

➢ From the History Tree, right click on CreateCylinder under Cylinder2 to change the 

dimensions and position of the cylinder. 

▪ Center Position: 5, 1, -5.3 mm 

▪ Axis: Z  

▪ Radius: 1 mm  

▪ Height: 4.8 mm  

▪ Number of Seg: 0  

➢ Select Apply  

➢ Select OK  

 

➢ From the History Tree, right click on the Cylinder2 to change its properties. 

▪ Name: Outer 

▪ Material: Teflon  

▪ Colour: blue  

▪ Transparency: 0.8  

➢ Select Apply  

➢ Select OK 
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10. CREATING THE GROUND PLANE.   

 

➢ From the Draw Ribbon Tab, select the rectangle tool.  

➢ In the Modeler Window, click and drag to draw the rectangle.  

 

➢ From the History Tree, right click on Create Rectangle under Rectangle3 to change the 

dimensions and position of the rectangle.  

▪ Position: -10 ,-2 ,-0.5 mm  

▪ Axis: Z  

▪ Xsize: 210 mm  

▪ Ysize: 320 mm  

➢ Select Apply  

➢ Select OK  

 

 

 

 

➢ Select Rectangle3 > Select Thicken Sheet > Set the value to 0.05 mm  

➢ From the History Tree, right click on the Rectangle3 to change its properties.  

▪ Name: Ground 

▪ Material: FR4 epoxy 

▪ Transparency: 0.6 

▪ Select Apply  

▪ Select OK  
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11. CREATING THE SUBSTRATE   

 

➢ From the Draw Ribbon Tab, select the Box tool  

➢ In the Modeler Window, click and drag from any point to draw the box.  

 

 

 

 

 

 

 

 

➢ From the History Tree, right click on CreateBox under Box1 to change the dimensions 

and position of the box. 

▪ Position: -10 ,-2 ,0 mm 

▪ Xsize: 210 mm  

▪ Ysize: 320 mm  

▪ Zsize: -0.5 mm  

➢ Select Apply  

➢ Select OK  
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➢ From the History Tree, right click on the Box1 to change its properties.  

▪ Name: Substrate 

▪ Material: Air  

▪ Colour: blue 

▪ Transparency: 0.8  

➢ Select Apply  

➢ Select OK  

 

 

 

12. MODELLING ANTENNA-2  

In modelling antenna 2, there are two options;  

1. Repeat the steps for creating the individual components but with different coordinates for 

their positions.  

2. Copy and paste the individual components, thereafter, change the coordinates for their 

positions.  
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Using Option 2  

❖ Copy and Paste the components.  

➢ In the History Tree, select Patch, Short, Feed, Outer, Circle  

➢ Press Ctrl + C to copy the selected components  

➢ Single click inside the Modeller Window  

➢ Press Ctrl + V to paste the components  

 

❖ Change the coordinates of the components.  

➢ Select the Create Rectangle under Patch1  

➢ Type the new coordinates for the Position as shown in the table below.  

➢ Repeat this step for the other pasted components using their new coordinates.  

Component  Coordinates  

Patch1  0 , 313 , 0 mm  

Short1  0 , 313 , 0 mm  

Feed1  5 , 314 , -5.3 mm  

Outer1  5 , 314 , -5.3 mm  

Circle1  5 , 314 , -5.3 mm  

 

❖ Creating Radiation Box  

➢ From the Draw Ribbon Tab, select the Box tool  

➢ In the Modeler Window, click and drag from any point to draw the box. 
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➢ From the History Tree, right click on CreateBox under Box1 to change the dimensions and 

position of the box.  

▪ Position:-100 ,-100 ,-5.3 mm  

▪ Xsize: 400 mm  

▪ Ysize: 500 mm  

▪ Zsize: 60 mm  

➢ Select Apply  

➢ Select OK  

 

 

➢ From the History Tree, right click on the Box1 to change its properties.  

▪ Name: RadBox  

▪ Material: Vacuum  

▪ Colour: green  

▪ Transparency: 0.9  

➢ Select Apply  

➢ Select OK  

 

 

 

 

13. ASSIGNING BOUNDARIES AND EXCITATIONS 

Radiation Boundary  

The purpose of using boundary conditions in HFSS is to define the behaviour of the 

electromagnetic. Field on the object interfaces and at the edges of a problem region. Defining 

boundary conditions reduces the electromagnetic or geometric complexity of the model.  

➢ Create Boundary  

➢ Right click on RadBox inside the History Tree.  

➢ Select Assign Boundary from the pop-up.  

➢ Select Radiation.  

➢ Select Ok from the pop-up.  
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Wave Ports  

Wave ports are used to excite transmission lines like microstrip, and hollow waveguides. A wave 

port represents the region through which electromagnetic energy enters or exits the solution space. 

In HFSS a wave port is treated as if it were a semi-infinitely long wave guide or transmission line 

of the exact same cross-section attached to them where it’s excited. Wave ports yield S, Y, Z 

parameters, characteristic wave impedance and the propagation constant gamma. The S-

parameters generated by a wave port are normalized to the matched loads and can also be 

normalized to any constant complex impedance. 

 

❖ Create Excitation  

➢ Right click Circle inside the History Tree 

➢ Select Assign Excitation from the pop-up 

➢ Select Wave port  

➢ Right click None from the pop-up  

➢ Select New Line.  

➢ In the Modeller Window draw a line from 

the centre of the circle to its circumference.  

➢ Ensure that the None has changed to Defined  

➢ Click Next at the bottom of the pop-up. 

➢ Select Finish.  
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➢ Repeat the above steps for Circle1 to create the wave port for Antenna-2.  

 

14. SPECIFYING SOLUTION SETTINGS 

 

❖ Performing Analysis Setup  

➢ Right click on HFSS on the Menu Bar.  

➢ Select Analysis Setup from the drop down menu.  

➢ Select Add Solution Setup.  

➢ Select Advanced.  

➢ Select Multi-Frequencies under Adaptive Solutions  

➢ Fill out the details as shown in the second image below 
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➢ Select OK.  

➢ In the next pop-up window, select Fast under Sweep Type.  

➢ Under Frequency Sweeps change the following parameters:  

▪ Start: 0 GHz  

▪ End: 8 GHz 

➢ Select OK.  

 

 

 

 

 

❖ Inserting Far Fields 

➢ Right click on HFSS on the Menu Bar.  

➢ Select Radiation from the drop 

down menu.  

➢ Select Insert Far Field Setup. 

➢ Select Infinite Sphere.  
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➢ Fill in the section under Phi with the following 

parameters.  

▪ Start: -180  

▪ Stop: 180  

▪ Step Size: 1  

 

➢ Fill in the section under Theta with the following 

parameters.  

▪ Start: 0 

▪ Stop: 360   

▪ Step Size: 1  

➢ Click OK.  

➢ Apply Design Settings.  

 

➢ Right click on HFSS on the Menu Bar.  

➢ Select Design Settings from the drop down menu. 

➢ Select the Validations tab.  

➢ Check the box for Skip Intersection Checks.  

➢ Click OK.  

 

❖ Perform Validations  

➢ Right click on HFSS on the Menu Bar.  

➢ Select Validation Check from the drop down 

➢ menu.  

➢ Ensure all Validation Checks have been 

completed.  

➢ Click Close.  
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15. RUN HFSS TRANSIENT SIMULATION 

 

❖ Run Simulation  

➢ Select Simulation on the Ribbon Tab.  

➢ Click Analyze All.  

 

 

16. PLOTTING THE RESULTS 

 

❖ Plotting the S Parameters.  

➢ Click on Results on the Ribbon Tab.  

➢ Select Modal Solution Data Report.  

➢ Select the 2D Graph on the menu.  

 

 

➢ Select the following parameters in the pop-up 

menu 

➢ Category: S Parameter  

➢ Quantity: S(1,1)  

➢ Function: dB  

➢ Click on New Report.  
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❖ Plotting the Radiation Pattern  

➢ Click on Results from the Ribbon Tab.  

➢ Click on Far Fields Report.  

 

 

➢ Select 3D Polar from the drop down 

menu.  

➢ Select the following parameters in the 

pop-up menu  

▪ Sources: 1:1  

▪ Category: Gain  

▪ Quantity: GainTotal  

▪ Function: dB  

➢ Click on New Report.  
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SECTION 2: HORN-FED REFLECTOR ANTENNA 

Prepared by: Kwakye Akosah Jeffrey & Emmanuel Frimpong (Telecom Eng. 2021) 

 

INTRODUCTION 

Ansys HFSS is a 3D electromagnetic (EM) simulation software that can be used to design and 

simulate high-frequency electronic items including antennas, antenna arrays, RF or microwave 

components, high-speed interconnects, filters, connectors, IC packages, and printed circuit boards. 

Ansys HFSS software is used by engineers all over the world to develop high-frequency, high-

speed electronics that can be found in communications networks, advanced driver assistance 

systems (ADAS), satellites, and internet-of-things (IoT) devices. 

This document is intended to show you how to create, simulate, and analyze horn-fed reflector 

antenna system efficiently, using the ANSYS Electronics Desktop; HFSS and HFSS-IE Design 

Environments. 

This example is intended to show you how to create, simulate, and analyze horn-fed reflector 

antenna system efficiently, using the ANSYS Electronics Desktop; HFSS and HFSS-IE Design 

Environments. 

The design process is divided into 4 main parts namely; 

1. Part 1: HFSS Design of horn antenna  

2. Part 2: HFSS-IE design of reflector with excitation linking to HFSS design in part 1. 

Antenna solution using an Integral Equation and Physical Optics solution methods, both 

techniques are available within HFSS-IE. 

3. Part 3: HFSS Hybrid design of a reflector + horn antenna  

4. Part 4: Design simulations and results 
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1. LAUNCHING ANSYS ELECTRONICS DESKTOP  

 

➢ Select Programs > ANSYS Electromagnetics > ANSYS Electromagnetics Suite 16.0  

➢ Select ANSYS Electronics Desktop 2016. 

 

2. SETTING TOOL OPTIONS 

 

➢ Note: In order to follow the steps outlined in this example, verify that the following tool 

options are set:  

➢  Select the menu item Tools > Options > HFSS Options… 

– Click the General tab  

➢ Use Wizards for data input when creating new boundaries: √ Checked  

➢ Duplicate boundaries/mesh operations with geometry: √ Checked  

– Click the OK button  

➢ Select the menu item Tools > Options > Modeler Options….  

– Click the Operation tab  

➢ Automatically cover closed polylines: 

√ Checked  

➢ Select last command on object select: √ 

Checked  

– Click the Drawing tab  

➢ Edit properties of new primitives: √ 

Checked  

– Click the OK button 

 

 

 

PART 1 – HFSS: CREATING THE HORN ANTENNA 

❖ Opening a New Project 

➢ In HFSS Desktop, click the  On the Standard toolbar, or select the menu item File > 

New.  

 

For basic design tutorials using HFSS: 

https://www.youtube.com/playlist?list=PLdIVd39LNkpSaTzAFCS_jh3sV3Gc21mNg  

https://www.youtube.com/playlist?list=PLdIVd39LNkpSaTzAFCS_jh3sV3Gc21mNg
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➢ From the Project menu, select Insert HFSS Design. 

 

❖ Set Solution Type 

➢ Select the menu item HFSS > Solution Type  

– Choose Driven Modal  

– Choose Network Analysis  

– Click the OK button 

 

❖ Set Model Units 

➢ Select the menu item Modeler > Units  

– Select Units: in  

– Click the OK button 

➢ Select The Menu Item Draw > 3D Component Library 

> Browse  

– Browse 3D Component Dialog  

➢ Filename: Horn_10GHz.a3dcomp  

➢ Click the Open button  

– Insert 3D Component Dialog  

➢ FlareA: 2.65in  

➢ FlareB: 1.95in  

➢ Horn_length: 5.2in  

➢ Click the OK button  

➢ To fit the view:  

– Select the menu item View > Fit All > 

Active View OR press the CTRL+D key 

 

3. CREATING THE AIRBOX 

 

➢ Select the menu item Draw > Region  

– Padding Data: Pad all directions 

similarly 

– Direction: All 

 – Padding type: Absolute Offset  

– Value: 0.3in  

– Click 

the OK 

button 
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4. CREATE RADIATION BOUNDARY  

 

➢ Select the menu item Edit > Select > By 

Name  

– Object Name: Region  

– Click the OK button  

➢ Select the menu item HFSS > Boundaries 

> Assign > Radiation…  

– Click the OK button 

 

5. CREATE A RADIATION SETUP 

 

➢ Select the menu item  

HFSS > Radiation > Insert Far Field Setup > Infinite Sphere  

– Infinite Sphere Tab  

➢ Name: 2D  

➢ Phi: (Start: 0, Stop: 90, Step Size: 90)  

➢ Theta: (Start: -180, Stop: 180, Step Size: 

1)  

– Click the OK button 

 

6. CREATING AN ANALYSIS SETUP  

 

➢ Select the menu item HFSS>  

Analysis Setup > Add Solution Setup  

– Click the General tab: 

➢ Solution Frequency: 10 GHz  

➢ Maximum Number of Passes: 6  

➢ Maximum Delta S per Pass: 0.02 

– Click the OK button 
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7. SAVE PROJECT  

 

➢ Select the menu item File > Save As  

– Filename: Reflector  

– Click the Save button  

➢ Source Design Analyze  

➢ Select the menu item HFSS > Analyze All 

 

PART 2: CREATING THE 3D MODEL 

 

❖ Create Reflector 

➢ Select the menu item Draw > Equation Based 

Curve  

– X(_t): 0  

– Y(_t): (_t)*(1cm)  

– Z(_t): (26.625-_t*_t/106.5)*(-1cm) 

– Start_t: 0  

– End_t: 32  

– Number of Points: 0  

– Click the OK button  

➢ Select the menu item Edit > Select All 

➢ Select the menu item Draw > Sweep Around Axis  

– Sweep axis: Z 

– Angle of sweep: 360 deg  

– Draft angle: 0 

– Draft type: Round  

– Number of segments: 0  

– Click the OK button 
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8. ASSIGN PEC  

 

➢ Select the menu item Edit > Select All  

➢ Select the menu item HFSS-IE > Boundaries > 

Assign > Perfect E  

– Click the OK button 

 

9. CREATE LINKED EXCITATION 

 

➢ Select the menu item HFSS-IE > Excitations > 

Assign > Incident Wave > Near Field Wave 

– General Data  

➢ Name: Feed  

➢ Vector Input Format: Cartesian  

➢ Click the Next button  

– Near Field Wave options  

➢ Theta (rotation about the resultant X-axis): 180deg  

➢ Click the Setup Link button  

– Product: HFSS  

– Source Project: √ Use This Project  

– Source Design: HFSSDesign1  

– Source Solution: Setup1: Last Adaptive – Simulate source design as needed: √  

– Preserve source design solution: √  

– Click the OK button 
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PART 3: HFSS HYBRID DESIGN OF A REFLECTOR + HORN ANTENNA 

After the creation of the horn, we export it as a 3D component and save it on a desired location on 

our computer. Next, we design the parabolic reflector and save it as a separate component on any 

location on the computer. Finally, we include the two components to obtain our parabolic reflector 

antenna.  

The horn is positioned such that its aperture is directly facing the inside surface of the parabolic 

reflector with the aim of collecting and recycling electromagnetic emissions. The coordinate 

system employed in this set up is the reflector focus coordinate system. 

Next, a solution setup is added to the two components. After adding a solution set up, we do a 

frequency sweep for our design. This is where we indicate the frequency range in which our design 

should operate. We set the step size 0.05GHz. 
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10. PART 4: 3D PATTERN RESULTS 

 

➢ Create 3D Far Field Pattern for IE Solution  

– Select the menu item HFSS-IE > Results > Create Far Fields Report > 3D Polar 

Plot  

➢ Solution: IE_Setup: LastAdaptive  

➢ Geometry: 3D  

➢ Primary Sweep: Phi  

➢ Secondary Sweep: Theta  

➢ Category: Directivity  

➢ Quantity: DirTotal  

➢ Function: dB  

➢ Click the New Report button 

 

 

 

 

NB: For results and discussion, refer to chapter 4 of our project report. 
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34 

 

SECTION 3: SPHERICAL PHANTOM DESIGN FOR SPECIFIC 

ABSORPTION RATE (SAR) SIMULATION 

Prepared by: Philip Arthur (MPhil. Telecom Eng. 2021) 

 

INTRODUCTION 

With the increasing consumer demand for wireless devices, consumers and the media have become 

aware of and are concerned with the biological effects of long-term exposure to radio frequency 

radiation (RFR). To ensure public safety, the Federal Communication Commission (FCC) has 

developed safety standards that wireless devices are required to meet in order to be sold in the US 

(Similar guidelines exist in other countries). The quantity used to quantify the amount of energy 

absorbed is the Specific Absorption Rate or SAR [1]. The specific absorption rate which is defined 

as the amount of electromagnetic energy absorbed per-unit mass by the human body when using a 

wireless communication device and can be represented mathematically as: 

𝑆𝐴𝑅 =
𝜎 × 𝐸2

𝜌
    (1) 

Where 𝝈 is the conductivity of the body tissue (𝑆/𝑚), 𝑬 expresses the RMS electric field intensity 

(𝑉/𝑚) and 𝝆 denotes the mass density of the body tissue (𝐾𝑔/𝑚3). According to the IEEE C95.1-

2005 standard for safety levels with respect to human exposure to RF energy, SAR limit is set to 

1.6 W/kg and 2 W/kg over 1g and 10 g of contiguous tissue respectively by the FCC and 

International Commission on Non-Ionizing Radiation Protection (ICNIRP).  

This example is intended to show you how to create, simulate, and analyze a simple phantom, 

which is commonly used to calibrate Specific Absorption Rate test equipment, using the Ansoft 

HFSS Design Environment. 

 

 

For basic design tutorials using HFSS: 

https://www.youtube.com/playlist?list=PLdIVd39LNkpSaTzAFCS_jh3sV3Gc21mNg 

 

 

 

 

https://www.youtube.com/playlist?list=PLdIVd39LNkpSaTzAFCS_jh3sV3Gc21mNg
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1. CREATE BOWL 

 

➢ Select the menu item Draw > Sphere 

➢ Using the coordinate entry fields, enter the sphere position 

- X: 0.0, Y: 0.0, Z: 56.5, Press the Enter key 

➢ Using the coordinate entry fields, enter the radius: 

- dX: 56.5, dY: 0.0, dZ: 0.0, Press the Enter key 

➢ Change name of Sphere1 to Bow1 

 

 

 

2. SET MATERIAL PROPERTIES (View/Edit Material Window) 

➢ Change material name to My_Bowl 

➢ For the Value of Relative Permittivity type: 4.6 

➢ Click the OK button 
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3. CREATE OFFSET COORDINATE SYSTEM 

 

➢ Select the menu item 3D Modeler > Coordinate System > Create > Relative CS > 

Offset 

➢ Using the coordinate entry fields, 

enter the origin 

- X: 0.0, Y: 0.0, Z: 81.5, Press 

the Enter key 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

4. CREATE THE OPENING IN THE BOWL 

 

➢ Right click Bowl > Edit > Boolean > Split 

➢ Split Window: 

- Split Plane: XY 

- Keep Fragments: Negative Side 

- Click the OK button 
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5. CREATE BRAIN FLUID 

 

➢ Set the working coordinate system (CS): Global or 

simply click on the Global CS 

➢ Select the menu item Draw > Sphere 

➢ Using the coordinate entry fields, enter the sphere 

position 

- X: 0.0, Y: 0.0, Z: 56.5, Press the Enter key 

➢ Using the coordinate entry fields, enter the radius: 

- dX: 51.5, dY: 0.0, dZ: 0.0, Press the Enter key 

➢ Change name Sphere1 to BrainFluid 
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6. SET MATERIAL PROPERTIES (View/Edit Material Window) 

 

➢ Change material name to My_BrainFluid 

➢ For the Value of Relative Permittivity type: 42.9 

➢ For the Value of Bulk Conductivity type: 0.9 

➢ Click the OK button 
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7. CREATE THE SHELL OF THE BOWL 

 

➢ Select the objects: Bowl, BrainFluid 

➢ Clone tool objects before subtracting: √ Checked 

➢ Click the OK button 

 

8. CREATE OFFSET COORDINATE SYSTEM 

 

➢ Select the menu item 3D Modeler > Coordinate 

System > Create > Relative CS > Offset 

➢ Using the coordinate entry fields, enter the origin 

- X: 0.0, Y: 0.0, Z: 69, Press the Enter key 

 

 

 

9. SET THE FLUID LEVEL 

 

➢ Right click BrainFluid > Edit > Boolean > Split 

➢ Split Window 

- Split Plane: XY 

- Keep Fragments: Negative Side 

- Click the OK button 
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10. CREATE AIR BOX 

 

➢ Select the menu item Draw > Box 

➢ Using the coordinate entry fields, enter the box position 

- X: -150.0, Y: -150.0, Z: -150.0, Press the Enter key 

➢ Using the coordinate entry fields, enter the opposite corner of the 

base rectangle: 

- dX: 300.0, dY: 300.0, dZ: 300.0, Press the Enter key 

➢ Change name of Box1 to Airbox 

 

1. CREATE RADIATION BOUNDARY 

 

➢ Right click Airbox > Assign Boundary 

> Radiation  

➢ Radiation Boundary Window: 

- Name: Rad1 

- Click the OK button 

 

 

 



41 
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SECTION 4: PIN DIODE MODELLING FOR ON/OFF SWITCHING IN 

RECONFIGURABLE ANTENNAS USING HFSS 2018 

Prepared by: Philip Arthur (MPhil. Telecom Eng. 2021) 

 

INTRODUCTION 

Antenna reconfiguration has become an important feature in modern wireless communications 

such as MIMO systems, cognitive radio, 5G and satellite communication systems, IoT networks, 

and smartphones [4]. A reconfigurable antenna is capable of changing its performance 

characteristics (resonant frequency, radiation pattern, polarization, etc.) by mechanically or 

electrically modifying its architecture [5]. The basic goal of a reconfigurable antenna is to achieve 

more functionality with a single antenna element or an array. 

 

(a)                                                                (b)                            (c) 

Fig.1 PIN Diode (a) Basic structure [50] (b) Equivalent forward bias circuit (c) Equivalent reverse 

bias circuit. 

The PIN diode is a simple technique of electronically modifying the functional properties of the 

antenna by the switching states of the diode. The PIN diode conducts current in one direction only 

and therefore determines the ON and OFF states respectively. When the diode is forward biased 

(ON state) the equivalent circuit is a combination of parasitic inductance 𝐿 and a series resistance 

𝑅𝑠 as shown in Fig.4.0 (b). When a reverse-biased voltage is applied, the diode is known to operate 

in the OFF state with the equivalent circuit containing a large resistance (𝑅𝑝) in shunt with a 

capacitor as shown in Fig.4.0 (c). This effect can be modeled as an RLC boundary in HFSS. 

This example is intended to show you how to create, simulate, and analyze a PIN diode in a simple 

transmission line using the Ansoft HFSS Design Environment. 
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For basic design tutorials using HFSS: 

https://www.youtube.com/playlist?list=PLdIVd39LNkpSaTzAFCS_jh3sV3Gc21mNg 

 

1. CREATE DIELECTRIC SUBSTRATE 

 

➢ Select the menu item Draw > Box 

➢ Using the coordinate entry fields, enter the 

sphere position 

- X: -14.4, Y: -14.4, Z: 0, Press the Enter key 

➢ Using the coordinate entry fields, enter the 

radius: 

- dX: 28.8, dY: 28.8, dZ: 1.6, Press the 

Enter key 

➢ Change name of Box1 to Substrate 

 

2. SET MATERIAL PROPERTIES (View/Edit Material Window) 

 

➢ Assign material: FR-4 epoxy 

➢ Click the OK button 

 

 

https://www.youtube.com/playlist?list=PLdIVd39LNkpSaTzAFCS_jh3sV3Gc21mNg
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3. CREATE GROUND PLANE 

 

➢ Select the menu item Draw > Rectangle 

➢ Using the coordinate entry fields, enter the sphere 

position 

- X: -14.4, Y: -14.4, Z: 0, Press the Enter key 

➢ Using the coordinate entry fields, enter the radius: 

- dX: 28.8, dY: 28.8, dZ: 0, Press the Enter key 

➢ Change name of Rectangle1 to groundplane 

 

4. CREATE TRANSMISSION LINE 

 

➢ Select the menu item Draw > Rectangle 

➢ Using the coordinate entry fields, enter the 

sphere position 

- X: -14.4, Y: -1, Z: 1.6, Press the Enter 

key 

➢ Using the coordinate entry fields, enter the 

radius: 

- dX: 28.8, dY: 2, dZ: 1.6, Press the Enter key 

➢ Change name of Rectangle1 to TL 

 

5. CREATE SLOT 

 

➢ Select the menu item Draw > Rectangle 

➢ Using the coordinate entry fields, enter the sphere position 

- X: -1, Y: -1, Z: 1.6, Press the Enter key 

➢ Using the coordinate entry fields, enter the radius: 

- dX: 2, dY: 2, dZ: 1.6, Press the Enter key 

➢ Change name of Rectangle1 to slot 

 

6. ASSIGN MATERIAL 

 

➢ Select groundplane and TL 

➢ Right click > Assign Boundary > Perfect E 

➢ Click OK for PerfE1 
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7. CREATE PORTS 

➢ Change drawing plan from default XY to YZ 

➢ Select the menu item Draw > Rectangle 

➢ Using the coordinate entry fields, enter the 

sphere position 

- X: -14.4, Y: -2, Z: 0, Press the Enter key 

➢ Using the coordinate entry fields, enter the 

radius: 

- dX: 0, dY: 2, dZ: 1.6, Press the Enter key 

➢ Change name of Rectangle1 to port1 

➢ Duplicate along line to create port2 (click and 

drag)  

 

8. ASSIGN EXCITATION 

 

➢ Right click port1 > Assign Excitation > Lumped 

port 

➢ Draw integration line from bottom to top of port1 

➢ Right click port2 > Assign Excitation > Lumped 

port 

➢ Draw integration line from bottom to top of port2  
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9. CREATE RLC BOUNDARY 

 

➢ Change drawing plan from YZ to XY 

➢ Select the menu item Draw > Rectangle 

➢ Using the coordinate entry fields, enter the sphere position 

- X: -1, Y: -1, Z: 1.6, Press the Enter key 

➢ Using the coordinate entry fields, enter the radius: 

- dX: 0.5, dY: 2, dZ: 1.6, Press the Enter key 

➢ Change name of Rectangle1 to C1 (Blocking capacitor 1) 

➢ Duplicate along line to create 3 other rectangles (click and drag) in the same slot. 

➢ Rename other ending rectangle as C2, middle 2 rectangles as L and R 
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10. ASSIGN RLC BOUNDARY 

 

➢ Right click C1 > Assign Boundary > Lumped RLC 

➢ Draw integration line in the chosen direction of the current flow. 

➢ Set C1 and C2 = 0.5uF (ON state) 

➢ Right click L > Assign Boundary > Lumped RLC 

➢ Draw integration line in the chosen direction of the current flow (same direction as C1). 

➢ Set L = 0.4nH, R = 2 Ω (ON state) 

- For OFF state: 

- Set C1 and C2 = 32fF  

- Set L = 0.4nH, in parallel with R = > 15 kΩ (ON state) 

-  
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11. CREATE AIR BOX 

 

➢ Select the menu item Draw > Box 

➢ Using the coordinate entry fields, enter the 

box position 

- X: -50.0, Y: -50.0, Z: -50.0, Press the 

Enter key 

➢ Using the coordinate entry fields, enter the 

opposite corner of the base rectangle: 

- dX: 100.0, dY: 100.0, dZ: 100.0, 

Press the Enter key 

➢ Change name of Box1 to Airbox 

 

12. CREATE RADIATION BOUNDARY 

 

➢ Right click Airbox > Assign Boundary > 

Radiation 

➢ Radiation Boundary Window:  

➢ Name: Rad1 

➢ Click the OK button 
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13. SIMULATION (ANALYSIS) SET UP 

 

➢ Right click Analysis > Add Solution Set up 

➢ Driven Solution Set up window: 

- Set frequency = 2.4 GHz 

- Set Maximum Number of passes = 20 

- Maximum Delta S = 0.02 

- Click OK 

➢ Right click on Setup1 > Add Frequency Sweep  

➢ Edit frequency sweep window: 

- Set frequency sweep from 1GHz – 5GHz 

- Click OK 

- Validate 

- Analyze 
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14. PLOTTING RESULTS 

 

❖ (When PIN diode is switched ON) 

 

➢ Right click on Results > Create Modal Solution Data Report > Rectangular Plot  

➢ In the New Report dialog box 

- Solution setup1: Sweep 

- Domain: Sweep 

- Primary Sweep: Frequency (All) 

- Category: S Parameter 

- Quantity: S(1,1) 

- Function: dB 

- Click New Report 
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➢ Right click on TL > Plot Fields > E > Mag_E 

➢ Create Field Plot window : Click Done 

➢ Right click on Mag_E1 > Animate  

➢ Set up Animation window: click OK 
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❖ (When PIN diode is switched OFF)  

 

➢ Set parallel combination of R and C from the Boundaries and simulate (analyze all) – 

Refer to section 10. 

➢ Right click on Results > Create Modal Solution Data Report > Rectangular Plot  

➢ In the New Report dialog box 

- Solution setup1: Sweep 

- Domain: Sweep 

- Primary Sweep: Frequency (All) 

- Category: S Parameter 

- Quantity: S(1,1) 

- Function: dB 

- Click New Report 

➢ Right click on TL > Plot Fields > E > Mag_E 

➢ Create Field Plot window : Click Done 

➢ Right click on Mag_E1 > Animate  

➢ Set up Animation window: click OK 
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SECTION 5: MODELLING BENDING FEATURES IN FLEXIBLE 

ANTENNAS USING CST 2019 

Prepared by: Philip Arthur (MPhil. Telecom Eng. 2021) 

 

INTRODUCTION 

The demand for wearable electronics to establish wireless body area communication has been 

growing rapidly. This places unique requirements on some electronic devices to possess 

conformable features. The flexibility feature has some striking advantages over its fixed 

counterparts in wearable applications. Due to the random postures of the host body, poor 

performance effects may result from the operation of these devices. Several applications of body-

worn sensors in health monitoring, sports and entertainment, emergency services and the military 

present the demand for flexible antennas. Hence, the simulation and design techniques to address 

the conformable features and its effects in such systems is equally important. 

This guide is intended to show you how to apply bending features to an already designed slotted 

planar monopole antenna using the Computer Simulation Technology (CST) EM tool. CST Studio 

Suite is a high-performance 3D EM analysis software package for designing, analyzing and 

optimizing electromagnetic (EM) components and systems [6].  

 

 

 

 

 

 

 

 

 

 

 

Fig.1 Applications of Flexible antennas [8]-[11] 
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1. LAUNCHING CST 

 

➢ Select Programs > CST Studio Suite 2019  

➢ Close quick introduction video window. 

 

➢ Click on > New Project Template >  
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➢ Click on Microwaves & RF/Optical > Antennas 

 

 

➢ Click on > Planar (Patch, Slot, etc.) > Next 
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➢ Click on > Time Domain > Next 

 

➢ Set the units 
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➢ Set frequency from 2 -3 GHz > Check E-filed, H-field and Far field > Next 

 

 

➢ Change name of project 
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2. HIDING THE BOUNDING BOX 

 

➢ Go to > View > Uncheck Bounding Box 

 

 

3. ANTENNA BENDING 

 

➢ Perform outward cylindrical bending along the x-axis (u-axis; local coordinate)  

➢ Select component1 > Go to Bending Tools > Cylindrical Bending 

➢ Cylindrical Bend Window: 

- Impact direction: Two sided 

- Bending Parameters: Select Angle = -90 or choice of angle 

- Preview; OK  
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For basic bending and antenna modelling tutorials in CST: 

https://www.youtube.com/watch?v=nnnr0ccXOmE  

https://www.youtube.com/c/tensorbundle/videos  

  

 

 

 

 

https://www.youtube.com/watch?v=nnnr0ccXOmE
https://www.youtube.com/c/tensorbundle/videos
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